未开启cookie无法登录使用i春秋的完整服务,请设置开启浏览器cookie

进入企安殿 进入助教后台
课程库  >   知识体系   >   JBoss 反序列化漏洞(CVE-2017-12149)   >   JBoss 反序列化漏洞(CVE-2017-12149)

【温馨提示】

  Flash加载失败,请按以下提示检查您的Flash问题:

  1. 请确认是否安装最新版本Flash,如提示Flash版本低,请更新

  2. 请确认浏览器中Flash插件是否启用,不同浏览器检查方法如下:

  • Safari浏览器:偏好设置-安全性-互联网插件-勾选“允许插件”-插件设置-确认“Adobe Flash Player”勾选
  • Chrome浏览器:偏好设置-显示高级设置-内容设置-Flash区域选择“允许网站运行Flash”
  • IE浏览器:Internet选项-高级-点击“重置”
  • 下载更新
    播放器版本切换

    温馨提示:您当前浏览器不支持HTML播放器

    试看结束,请登录后观看完整视频

    目录
    实验
    课件
    JBoss 反序列化漏洞(CVE-2017-12149)
    课时1
    JBoss 反序列化漏洞(CVE-2017-12149) 11分钟
    0%
    弹幕

    我的弹幕

    • 字号
    • 位置
    • 颜色

    显示设置

    屏蔽弹幕

    • 顶部
    • 底部
    • 滚动

    透明度

    100%
    发送
    关注(65
    点赞(28
    手机看

    JBoss 反序列化漏洞(CVE-2017-12149)
    课程目录
    课程讨论(0
    i春秋
    关注(18686
    好评度
    96%
    课程节数
    580
    课程信息

    课程难度:初级

    学习人数:38828

    课程状态:已完结-共1节

    时长:6分钟

    课程介绍

    JBoss Application Server是一个基于J2EE的开放源代码的应用服务器。 JBoss代码遵循商业友好的LGPL许可,并且由开源社区开发,其良好的运行效率和安全性能使其广为流行。

    JBoss安全更新时会伴随漏洞通告,2017年8月30日,JBOSS厂商发布了一个JBOSSAS 5.x 的反序列化远程代码执行漏洞(CVE-2017-12149)的通告。该漏洞位于JBoss的HttpInvoker组件中的 ReadOnlyAccessFilter 过滤器中,其doFilter方法在没有进行任何安全检查和限制的情况下尝试将来自客户端的序列化数据流进行反序列化,导致恶意访问者通过精心设计的序列化数据执行任意代码。但近期有安全研究者发现JBossAS 6.x也受该漏洞影响,恶意访问者利用该漏洞无需用户验证即可获得服务器的控制权。该漏洞的细节和验证代码已公开,为避免造成损失,建议及时修复升级至JBossAS 7版本。

    本节课i春秋讲师复现了此漏洞的场景,分析了漏洞的成因,希望同学们了解漏洞原理,学习该漏洞利用技术,及时做好版本升级和安全防护。还在等什么,赶快点击课程开始实验吧!

    课程目标
    希望同学们了解JBoss 反序列化漏洞(CVE-2017-12149)原理,学习该漏洞利用技术,及时做好版本升级和安全防护。
    适合人群
    网络安全爱好者,白帽子
    课程标签

    客户端安全

    系统安全

    ×

    课程评价×

    课程与描述相符:非常满意

    课程内容的价值:非常满意

    老师讲解与表达:非常满意

    为了提供倍速播放、断点续看、学习时长记录等功能,推荐您使用Chrome、Firefox浏览器,点击下载 Chrome Firefox

    在线支付
    请在新打开的页面完成支付

    支付完成前请不要关闭本页面

    支付完成