未开启cookie无法登录使用i春秋的完整服务,请设置开启浏览器cookie

进入企安殿 进入助教后台
课程库  >   知识体系   >   Linux内存越界漏洞分析(CVE-2017-7184)   >   Linux内存越界漏洞分析(CVE-2017-7184)

【温馨提示】

  Flash加载失败,请按以下提示检查您的Flash问题:

  1. 请确认是否安装最新版本Flash,如提示Flash版本低,请更新

  2. 请确认浏览器中Flash插件是否启用,不同浏览器检查方法如下:

  • Safari浏览器:偏好设置-安全性-互联网插件-勾选“允许插件”-插件设置-确认“Adobe Flash Player”勾选
  • Chrome浏览器:偏好设置-显示高级设置-内容设置-Flash区域选择“允许网站运行Flash”
  • IE浏览器:Internet选项-高级-点击“重置”
  • 下载更新
    播放器版本切换

    温馨提示:您当前浏览器不支持HTML播放器

    试看结束,请登录后观看完整视频

    目录
    实验
    课件
    Linux内存越界漏洞分析(CVE-2017-7184)
    课时1
    Linux内存越界漏洞分析(CVE-2017-7184) 10分钟
    0%
    弹幕

    我的弹幕

    • 字号
    • 位置
    • 颜色

    显示设置

    屏蔽弹幕

    • 顶部
    • 底部
    • 滚动

    透明度

    100%
    发送
    关注(64
    点赞(2
    手机看

    Linux内存越界漏洞分析(CVE-2017-7184)
    课程目录
    课程讨论(0
    i春秋
    关注(18688
    好评度
    96%
    课程节数
    580
    课程信息

    课程难度:初级

    学习人数:23057

    课程状态:已完结-共1节

    时长:10分钟

    课程介绍

    Linux是一套开源和自由传播的类Unix操作系统,而Linux内核是大多数操作系统的核心部分,负责管理系统的进程、内存、设备驱动程序、文件和网络系统,决定着系统的性能和稳定性。

    在2017年的PWN2OWN大赛中,有参赛团队成功演示了基于Linux内核IPSEC框架的一个内存越界漏洞的利用,此漏洞的CVE编号为CVE-2017-7184。安全研究人员可利用此漏洞实现代码执行、权限提升等操作,从而获取目标机器的root权限。Linux内核应用范围甚广,我们经常使用的Android、CentOS、Ubuntu等都使用了Linux内核,且本次利用的IPSEC框架自Linux2.6就开始支持,所以漏洞影响较广,建议及时更新内核至最新版本。

    在本节课中,i春秋讲师复现了此Linux内存越界漏洞的场景,并深入分析漏洞的成因,希望同学们理解漏洞原理,掌握漏洞调试技术,及时做好内核升级和防护。还在等什么,赶快点击课程开始实验吧!

    课程目标
    复现了Linux内存越界漏洞(CVE-2017-7184)的场景,并深入分析漏洞的成因,希望同学们理解漏洞原理,掌握漏洞调试技术,及时做好内核升级和防护。
    适合人群
    网络安全爱好者,白帽子
    课程标签

    客户端安全

    系统安全

    ×

    课程评价×

    课程与描述相符:非常满意

    课程内容的价值:非常满意

    老师讲解与表达:非常满意

    为了提供倍速播放、断点续看、学习时长记录等功能,推荐您使用Chrome、Firefox浏览器,点击下载 Chrome Firefox

    在线支付
    请在新打开的页面完成支付

    支付完成前请不要关闭本页面

    支付完成