未开启cookie无法登录使用i春秋的完整服务,请设置开启浏览器cookie

进入企安殿 进入助教后台
课程库  >   知识体系   >   FFmpeg文件读取漏洞(CVE-2017-9993)   >   FFmpeg文件读取漏洞(CVE-2017-9993)

【温馨提示】

  Flash加载失败,请按以下提示检查您的Flash问题:

  1. 请确认是否安装最新版本Flash,如提示Flash版本低,请更新

  2. 请确认浏览器中Flash插件是否启用,不同浏览器检查方法如下:

  • Safari浏览器:偏好设置-安全性-互联网插件-勾选“允许插件”-插件设置-确认“Adobe Flash Player”勾选
  • Chrome浏览器:偏好设置-显示高级设置-内容设置-Flash区域选择“允许网站运行Flash”
  • IE浏览器:Internet选项-高级-点击“重置”
  • 下载更新
    播放器版本切换

    温馨提示:您当前浏览器不支持HTML播放器

    试看结束,请登录后观看完整视频

    目录
    实验
    课件
    FFmpeg文件读取漏洞(CVE-2017-9993)
    课时1
    FFmpeg文件读取漏洞(CVE-2017-9993) 3分钟
    0%
    弹幕

    我的弹幕

    • 字号
    • 位置
    • 颜色

    显示设置

    屏蔽弹幕

    • 顶部
    • 底部
    • 滚动

    透明度

    100%
    发送
    关注(64
    点赞(49
    手机看

    FFmpeg文件读取漏洞(CVE-2017-9993)
    课程目录
    课程讨论(0
    i春秋
    关注(18688
    好评度
    96%
    课程节数
    580
    课程信息

    课程难度:初级

    学习人数:24285

    课程状态:已完结-共1节

    时长:3分钟

    课程介绍

    FFmpeg是一个完整的跨平台解决方案,用于记录、转换流式传输音频和视频,可用于预览生成和视频转换的视频编码软件。目前有非常多的视音频软件或是视频网站、手机APP都采用了这个库,但是这个库历史上曝出的漏洞也非常之多。

    此次漏洞利用了FFmpeg可以处理HLS播放列表的特性,而播放列表可以引用外部文件。通过在AVI文件中添加自定义的包含本地文件引用的HLS播放列表,可以触发该漏洞并在该文件播放过程中显示本地文件的内容。经验证该漏洞可导致读取本地任意文件,危害较大。经研究人员验证,Google、Yahoo、Youtube等门户、视听网站以及支持流转码服务的业务已被爆出存在该漏洞。

    影响范围:

    经测试FFmpeg 3.2.2、3.2.5和2.6.8版本均存在该漏洞,其它版本未经系统性测试,请按漏洞检测脚本进行自行排查。

    本节课中i春秋复现了漏洞场景,希望同学们了解漏洞原理以及学会如何防御此漏洞的方法。还在等什么,赶快点击课程开始实验吧!

    课程目标
    了解FFmpeg文件读取漏洞的原理,学会如何防御此漏洞的方法。
    适合人群
    白帽子,爱好网络安全人员
    课程标签

    客户端安全

    软件安全

    ×

    课程评价×

    课程与描述相符:非常满意

    课程内容的价值:非常满意

    老师讲解与表达:非常满意

    为了提供倍速播放、断点续看、学习时长记录等功能,推荐您使用Chrome、Firefox浏览器,点击下载 Chrome Firefox

    在线支付
    请在新打开的页面完成支付

    支付完成前请不要关闭本页面

    支付完成