未开启cookie无法登录使用i春秋的完整服务,请设置开启浏览器cookie

进入企安殿 进入助教后台
课程库  >   知识体系   >   【S2-053】Struts2远程命令执行漏洞(CVE-2017-12611)   >   【S2-053】Struts2远程命令执行漏洞(CVE-2017-12611)

【温馨提示】

  Flash加载失败,请按以下提示检查您的Flash问题:

  1. 请确认是否安装最新版本Flash,如提示Flash版本低,请更新

  2. 请确认浏览器中Flash插件是否启用,不同浏览器检查方法如下:

  • Safari浏览器:偏好设置-安全性-互联网插件-勾选“允许插件”-插件设置-确认“Adobe Flash Player”勾选
  • Chrome浏览器:偏好设置-显示高级设置-内容设置-Flash区域选择“允许网站运行Flash”
  • IE浏览器:Internet选项-高级-点击“重置”
  • 下载更新
    播放器版本切换

    温馨提示:您当前浏览器不支持HTML播放器

    试看结束,请登录后观看完整视频

    目录
    实验
    课件
    【S2-053】Struts2远程命令执行漏洞(CVE-2017-12611)
    课时1
    【S2-053】Struts2远程命令执行漏洞(CVE-2017-12611) 2分钟
    0%
    弹幕

    我的弹幕

    • 字号
    • 位置
    • 颜色

    显示设置

    屏蔽弹幕

    • 顶部
    • 底部
    • 滚动

    透明度

    100%
    发送
    关注(123
    点赞(98
    手机看

    【S2-053】Struts2远程命令执行漏洞(CVE-2017-12611)
    课程目录
    课程讨论(0
    i春秋
    关注(18798
    好评度
    96%
    课程节数
    608
    课程信息

    课程难度:初级

    学习人数:29275

    课程状态:已完结-共1节

    时长:2分钟

    课程介绍

    还记得上周爆出的S2-052漏洞吗?这次他的兄弟“出生”了,学名S2-053。S2-053(CVE-2017-12611)是Apache Struts 2存在的远程代码执行漏洞。该漏洞源于在处理Freemarker标签时,如果程序员使用了不恰当的编码表达会导致远程代码执行,恶意访问者可以通过漏洞执行任意代码,严重威胁服务器安全。

    修复建议:

    升级Apache struts 至 2.5.12 版本 或者 2.3.34 版本。

    通过学习本课程,学员们能够了解S2-053漏洞形成的原因,掌握验证漏洞的方法,学会如何修复此漏洞。还在等什么,大家一起做实验吧!

    课程目标
    对S2-053漏洞有进一步的了解,学习漏洞形成的原因,掌握验证漏洞的方法,学会如何修复此漏洞。
    适合人群
    白帽子,爱好网络安全人员
    课程标签

    网站安全

    Web安全

    ×

    课程评价×

    课程与描述相符:非常满意

    课程内容的价值:非常满意

    老师讲解与表达:非常满意

    为了提供倍速播放、断点续看、学习时长记录等功能,推荐您使用Chrome、Firefox浏览器,点击下载 Chrome Firefox

    在线支付
    请在新打开的页面完成支付

    支付完成前请不要关闭本页面

    支付完成